Browser Requirements

Article

Browser Requirements

For optimal use SkillSaver requires a minimum web browser of Microsoft Internet Explorer 7.0 or higher, Mozilla Firefox 3.0 or higher, or any other Web browser compatible with these browsers. Microsoft Internet Explorer 6.0 is also supported, however due to it's age some features may function less then ideally.

If you are not sure of the version of your browser, select Help in the menu bar of your browser and choose About.

Windows Users

If you need to upgrade your Web browser software, follow one of the links listed below:

Macintosh Users

Compatible Web browsers include Firefox and Apple Safari.

Other Site-wide Requirements

SkillSaver also requires the following for maximum effectiveness:
  • Your browser Cookies must be enabled.
  • JavaScript must be enabled on your browser.

Selected Titles Require Adobe Flash

Some of SkillSaver titles contain "Simulated Exercises."  You must have the Adobe Flash plug-in (version 7 or higher) installed to view these simulations . You can download the free Flash Player plug-in here.

Views: 7608
Last Updated: 11-05-2009